[Samba] [SOLVED] replace Windows 2003 dc

Peter Beck peter at datentraeger.li
Fri Feb 22 06:55:20 MST 2013

Federico Nan <federico at nantec.com.ar> quatschte am Fri, Feb 22, 2013 at 08:36:56AM -0300:
> Wouw!
> And how do you handle the GPO and sysvol volumes? Did you copy them to the
> samba sysvol?
> I´ve been trying and it always fails in the fsmo transferring. Did you do
> this on the Windows MMC?

Hi Federico,

It was just a very basic test with a "naked" Windows 2003 DC and I did
not test GPO/Sysvol transfers (only checked adding a GPO to the samba dc
after removing the Windows DC, which was working perfect)

If transferred the fsmo rules with samba-tool. fsmo seize did not work
on my machine, there were always errors (can't remember excatly at the
moment), transfer had a timeout the first try, but the second run was
successful. I've also tried it with ntdsutil from Windows, exact the
same behaviour (first try - timeout) so i think this is "normal".
>From what I have seen it's also working with samba-tool the first time,
even when there is a timeout message (I've used --role=all). After one
run I left the computer to get some coffee and when I came back and checked 
the roles I could see that every role was now transferred...

The only thing I'm unsure is with dcpromo when demoting the Windows DC -
I always get a message with "holds the last replication of Application
Directory Partitions" - usually ForestDNS and DomainDNS partitions.
I've just selected "delete them" and so far there was no issue.

But as mentioned, I'm also doing this in a little test environment and
have often switched back to an earlier snapshot to try again...no long
term experience.. ;-) I'm still testing...


More information about the samba mailing list