[Samba] Samba 4 DC log.smd flooded with Conversion error

TAKAHASHI Motonobu monyo at monyo.com
Mon Feb 11 08:14:53 MST 2013

From: "Kinglok, Fong" <busywater at gmail.com>
Date: Sun, 10 Feb 2013 09:40:49 +0800

> Thank you for your help but…
> I execute some commands to make sure the locale is in UTF-8 by
> dpkg-reconfigure locales and even adding setting in /etc/environment
> and using utility like convmv to turn all file and folder into UTF-8 (in fact, they were in UTF-8 already.)
> I add option in smb.conf
> unix charset = UTF8
> dos charset is omitted as default (dos charset = CP850)
> However, when I run
> /usr/local/samba/bin/smbclient //localhost/Public -UAdministrator%'verysecurepasswd' -c 'ls'
> The same error in my log floods……

No, you have to set 'dos charset' parameter correctly. In my Japanese
environment, same errors occur unless I set "dos charset = CP932", which
means Japanese. It seems that you use Chinese.

TAKAHASHI Motonobu <monyo at monyo.com> / @damemonyo 

More information about the samba mailing list