[Samba] samba bind : samba b9_putrr: unhandled record type 0 (solved )

L.P.H. van Belle belle at bazuin.nl
Mon Dec 23 06:38:21 MST 2013

wel, this was very crazy. 

Resolving over the dns of the samba4 server didnt work any more also. 

I remove the samba server from the domain, cleared the ad, removed the dns entries. 
restarted dns on the windows server. 
added the dns entries for the 2 dc's again. 

did a domain join again with the samba4 dc and... error gone..  :-s  

very strange... 
and beside these errors : samba b9_putrr: unhandled record type 0 
no other errors. 

After te join, this file : _default.tsigkeys isnt created again. 

but again no errors, resolving works ok again. 

im guessing something corrupted within the samba database. 



>-----Oorspronkelijk bericht-----
>Van: belle at bazuin.nl [mailto:samba-bounces at lists.samba.org] 
>Namens L.P.H. van Belle
>Verzonden: maandag 23 december 2013 11:07
>Aan: samba at lists.samba.org
>Onderwerp: [Samba] samba bind : samba b9_putrr: unhandled record type 0
>Wel after 2-3 days and a few reboots, im seeing the following 
>message in my logs. 
>named[8845]: samba b9_putrr: unhandled record type 0
>Anybody knows whats going on now, nothing changed in my setup. 
>Just installed the second DC, as first no errors. 
>Now after a few reboots,  the same error as my first server. 
>does anybody knows this error. 
>I did add a CNAME for my ntp server in the dns on the windows server. 
>but that should not give any errors, was already having 
>multiple CNAMEs in my dns. 
>I also noticed that after the reboots, the file :  
>_default.tsigkeys is empty now.  ( /var/cache/bind )  where 
>the zone files are of bind. 
>How can i recreate this file? im betting this causes my errors. 
>To unsubscribe from this list go to the following URL and read the
>instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list