[Samba] Samba classicupgrade problem

Koenraad Lelong samba.k.lelong at ace-electronics.be
Thu Dec 19 01:32:46 MST 2013

op 17-12-13 18:15, Marc Muehlfeld schreef:
> Do you have all requirements installed?
> http://wiki.samba.org/index.php/Samba_4/OS_Requirements#Development_libraries_and_Programs

I installed samba4 with the sernet-packages, on a Ubuntu 12.04 virtual 
machine. I presume that installing that package takes care of the needed 

> Does your filesystem, where the sysvol share will be created in, support
> xattr?
> http://wiki.samba.org/index.php/Setup_and_configure_file_shares#Filesystem_support
That is a good point. I added that, but unfortunately it does not solve 
my problem.

Like I told in my first mail, I had a good classicupgrade before. But 
then I reverted the snapshot for two reasons : I added a Windows machine 
in the "old" domain to test with it, and the ip-addres of the DC was in 
the old subnet and I don't want that because I need to do tests before I 
migrate for real.
So I copied the new tdb's to the 'clean' DC and then modified the IP 
address of the DC and rebooted. Then I ran classicupgrade again, with my 
problem. I also tried without modifying the ip-address, but that does 
not help.

I have a feeling that I miss some file, because my groups are not 
exported, but AFAIK, I copied all tdb's.

FWIW, I'm using samba 4.0.11.

Thanks anyway,

Koenraad Lelong.

More information about the samba mailing list