[Samba] Can't connect to my NAS after samba 4 update

Richard llom richard.llom at gmail.com
Wed Dec 18 16:07:19 MST 2013

Tiemen Ruiten wrote:
> Do you know the samba version on your NAS? You might be running into
> this bug: https://bugzilla.redhat.com/show_bug.cgi?id=905996
My NAS is actually a commercial product (Buffalo Linkstation). I doubt they 
are running SAMBA on it. But if they do, they didn't deliver license file 
with it! :-)

> (BTW, first hit on google for 'Conversion error: Incomplete multibyte
I tried searching, too. But didn't come up with anything which seems 


> On 10-12-13 01:02, Richard llom wrote:
>> Hello,
>> I updated my system to samba 4:
>> [richard at chakra ~]$ uname -a
>> Linux chakra 3.10.18-1-CHAKRA #1 SMP PREEMPT Sat Nov 9 20:18:15 UTC 2013
>> x86_64 GNU/Linux
>> [richard at chakra ~]$ samba --version
>> Version 4.1.1
>> [richard at chakra ~]$ smbclient --version
>> Version 4.1.1
>> And now all of sudden I cannot any longer connect to my NAS, this is the
>> message I get in console:
>> [richard at chakra ~]$ smbclient --list linkstation
>> Enter richard's password:
>> Conversion error: Incomplete multibyte sequence()
>> protocol negotiation failed: NT_STATUS_INVALID_PARAMETER
>> Note that I do not need any credentials to connect to my NAS.
>> Before it just worked.

More information about the samba mailing list