[Samba] l can't "see" files on NFS mounts using 3.6.15, after upgrading from 2.2.8a

Jordan Verschuer jvsamba007 at gmail.com
Mon Dec 16 15:29:04 MST 2013

Sorry Steve, by … I meant etc. (yada yada)

The share folder is /p3/biograph, and for e.g. I can make a directory there
called karri,

mkdir /p3/biograph/karri

I can then mount a folder from an NFS server called karri (we have dns)
into the share as follows,

mount -F nfs karri:/home/karri /p3/biograph/karri

This mounts all the folders in the karri home folder into a folder called
karri on the share.

When I open this folder from a Windows or Samba client I can't see any
files, they're "hidden".

The files are there and can be seen on the actual samba server.

I can also paste files into the karri directory using Explorer or Finder
from the samba client but then they become hidden once I refresh the
Explorer or Finder window.

Accessing NFS mounts from samba clients worked seamlessly for us in 2.2.8a.

They weren't heavily accessed folders and we weren't opening files and
working on them while they lived in the NFS mount.

The main reason we use this is that the Samba share has limited disk space,

so for instance I can make a directory on an NFS server with lots of space
and call this folder Software (and server it up via NFS, i.e. add it to

I can then copy all our software installation files, say for e.g. Microsoft
Office (~600MB), into this folder using a Samba client,

I can then go to another PC without Office installed, map the Samba share,
and copy the MS Office installation files (that are now living on the NFS
server but can be accessed via the Samba share) to this new PC,

once copied over to the new PC I can install MS office. Our computer guys
here that would be installing software would know not to start the
installation by running the software from the NFS directly, but that they
should copy it to the local first.

This is just an example but i'm trying to highlight that the files from the
NFS mounts wouldn't be "opened" directly from there,

the NFS mounts are simply a storage location.

I say this because i've seen a lot of "never share an NFS mount via samba"
posts due to file locking issues,

but since we're not opening files from there I don't see this as a major
problem for us, like i say, we're using it for storage only.

I hope this all makes sense!

And like i've mentioned before, this all worked in 2.2.8a without any
tinkering needed, so it's quite puzzling.

Thanks for your help,


On Tue, Dec 17, 2013 at 2:58 AM, steve <steve at steve-ss.com> wrote:

> > What command are you using to mount the nfs share?
> >
> >
> >
> >
> > ==> mount -F nfs… as for Solaris 9.
> Hi
> I had a quick look at the oracle docs but I don't think:
>  mount -F nfs...
> will mount anything. Are you sure that this command worked with your
> older version?
> Steve

More information about the samba mailing list