[Samba] [Samba 3, Debian wheezy] All of a sudden, resolving ADS user fails completely

Patrick G. Stoesser lists at pgs-info.de
Wed Dec 11 05:08:55 MST 2013

Am 10.12.2013 19:12, schrieb Harry Jede:
> On 18:48:34 wrote Patrick G. Stoesser:
>> Hello everybody.
>> since this morning I've got a massive problem.
>> My fileserver (Debian wheezy, Samba 3, everything up-to-date) is an
>> ADS member server and was running flawlessly for two weeks. Since a
>> few days I began to move users to this server from an old one, and
>> since this morning nothing works anymore.
>> The symptoms are: User get "wrong password" when trying to mount
>> shares. On the server itself users are not being resolved, too:
>> root at fileserver3:/home/remroot# ls -l /srv1
>> drwx------ 15 10039 root  4096 Jan 17  2013 user1
>> drwx------ 12 10030 root  4096 Nov  5 10:45 user2
>> drwx------ 11 10056 root  4096 Jun 27  2012 user3
>> Normally this should be like that (and like it was):
>> root at fileserver3:/home/remroot# ls -l /srv1
>> drwx------ 15 user1 root  4096 Jan 17  2013 user1
>> drwx------ 12 user2 root  4096 Nov  5 10:45 user2
>> drwx------ 11 user3 root  4096 Jun 27  2012 user3
>> Same thing when trying to chown (my winbind seperator is "#"):
>> root at fileserver3:/# chown -vR ad#user1 /srv1/user1
>> chown: ungültiger Benutzer: "ad#user1"
>> As said before, this worked yesterday, too.
>> /What/ works are the usual diagnosis things like wbinfo, wbinfo -g,
>> wbinfo -a username%password, net ads testjoin... Rejoining the ADS
>> didn't solve the problem either.
>> One more time: Since yesterday everything worked fine. Even more: The
>> same config is still working fine on three other servers.
>> Does anyone have any idea where I could look after? At the moment,
>> I'm at my wit's end.
> I have had a similiarly problem with one machine which has done an auto
> update yesterday evening. Update was from samba_3.6.6-6+deb7u1 to
> samba_3.6.6-6+deb7u2. Package server is ftp.de.debian.org
> The package.list files in /var/lib/dpkg/info/ did _not_ list any
> binaries :-( . And yes, no smbd, nmbd or winbindd was in /usr/sbin/
> So I downgraded to samba_3.6.6-6+deb7u1 which doesn't help, but sets the
> apt database to the last known good version. Then I have downloaded all
> packages manually via wget and installed them via dpkg -i package.deb
> The required packages for this installation are:
> samba-tools_3.6.6-6+deb7u1_i386.deb
> libsmbclient_3.6.6-6+deb7u1_i386.deb
> samba_3.6.6-6+deb7u1_i386.deb
> smbclient_3.6.6-6+deb7u1_i386.deb
> libwbclient0_3.6.6-6+deb7u1_i386.deb
> samba-common-bin_3.6.6-6+deb7u1_i386.deb
> winbind_3.6.6-6+deb7u1_i386.deb
> Today at 23:00 cet the next update is scheduled. I hope that this does
> not happen again. Otherwise I will force apt to stay on samba version
> 3.6.6-6+deb7u1.
>> Thanks in advance and kind regards, Patrick
Hell, right, there was an update! Ok, and it's the same thing here: 
Fortunately, on another server the update has not been applied. And on 
this server my config still works.
I so tried to downgrade my problem server to *deb7u1, but that did not work.
Appearently, the problem occurs since updating to *deb7u2.

Regards, Patrick

More information about the samba mailing list