[Samba] Migrate from Samba 4 to Samba 4?

Andrew Bartlett abartlet at samba.org
Fri Dec 6 11:30:39 MST 2013

On Thu, 2013-12-05 at 08:49 +0000, Kevin Latimer wrote:
> Hi Andrew,
> Thanks for the reply.  Sorry if I've jumped the gun by not wanting to try
> and fix "in place", sometimes it just seems easier to start again from a
> clean slate.  Also, sorry for the double-email Andrew, forgot to CC the
> list - this mail client is not overly list-friendly, I've had to handcraft
> the reply below as it doesn't allow bottom-posting...
> On Wed, 2013-12-04 at 11:08 +0000, Andrew Bartlett wrote: 
> > On Wed, 2013-12-04 at 10:40 +0000, Kevin Latimer wrote: 
> >> Hi All, 
> >> 
> >> Does anyone know if there's a Samba 4 to Samba 4 migration process? 
> >> Sounds weird, but it has a logical reason: 
> >> 
> >> I've a several-year-old S4 implementation, from an early Alpha (10 I 
> >> think?) that hasn't been in the best of shape of late - when S4 4.0.0 
> >> arrived, I accidentally upgraded using my normal "git 
> >> pull; ./configure; make; make install" procedure and instead of 
> >> getting 4.0 I got 4.1pre. I hastily installed the 4.0.0 tarball but I 
> >> think I've ended up with a broken schema because of it. 
> > The two trees were not that different at that point, so I don't think 
> > major harm came from this. 
> No probs, I just don't have a lot of faith in which schema I *do* have,
> as I'm missing the RFC2307 / SFU things that I wanted upgradeprovision
> to try to add :-)
> >> It's been clunking along okay nontheless with the oddities just 
> >> needing a little manual intervention now and again but last night I 
> >> decided to install the 4.1.2 tarball. 
> >> 
> >>  I wanted to do an "upgradeprovision --full" as I've been missing the 
> >> SFU schema and I need to retain some UID consistency. My testing on a 
> >> snapshot told me you can't run upgradeprovision with more than one DC 
> >> so last night, I allotted myself a maintenance window and went for it. 
> >> I demoted all the DC's but I had one that wouldn't demote (this DC is 
> >> one of the "manual interventions"...). I've tried samba-tool domain 
> >> demote, ntdsutil metadata cleanup, ADUC, ADSAS but it just won't 
> >> shift. 
> >> 
> >> Running out of time, I decided to upgrade to 4.1.2 on these two 
> >> remaining DC's anyway, do a fresh install on the other DC's and rejoin 
> >> them. They upgraded just fine but I can't join any other DC's, 
> >> samba-tool segfaults after copying the configuration partition. 
> > That's unfortunate. Can you get us some information on this segfault? 
> Sure.  I've just tried with a -d6 (a *lot* of output, much more than I
> allowed for with my scrollback!) and it segfaults with the following
> error at the end:
> dsdb_find_nc_root: Finding a valid 'namingContexts' element in the RootDSE failed. Using a temporary list.dsdb_find_nc_root: Finding a valid 'namingContexts' element in the RootDSE failed. Using a temporary list.../source4/dsdb/common/util.c:3116: WARNING: domainFunctionality not setup
> Segmentation fault
> I've got 20k lines of scrollback I can email to you if you like?  I'm not
> sure how much sensitive information might be in there for list posting...

Indeed.  You can send that to me personally. 

Also, most valuable would be to run it under gdb --args /usr/bin/python
samba-tool ....

Then run, (segfault), bt full. 

That backtrace is what I need to fix this. 

> Looking back though, these "Finding a valid 'namingContexts' element in
> the RootDSE failed" messages seem to all start around the part the sites and
> subnets start to get replicated.

We should get that once, when we first connect to the database. 

Andrew Bartlett

Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba

More information about the samba mailing list