[Samba] DNS_INFO_NO_RECORDS when trying to join domain

Lorenzo Milesi maxxer at ufficyo.com
Fri Dec 6 09:05:41 MST 2013

I've a Samba 3.4.7 running on Ubuntu 10.04 configured as PDC.
It has always worked but lately these months strange things started to happen: clients cannot join the domain anymore.
I had to reinstall a computer but when I tried to add it back to the domain I get this error message in Windows XP: DNS_INFO_NO_RECORDS. 
It seems windows cannot get server name via dns?

The samba server runs dnsmasq as dns server, and wins server is enabled.
It always worked but right now I don't know how to get out of this! 
I tried stopping everything and removing wins.dat but no change.

I don't know what else to check.
I don't know if this can matter but the LAN has a Win2003 machine acting as PDC just for itself. It always existed and coexisted with Samba's PDC without problems. I didn't change anything to that recently, and if can help I tried joining that domain and doesn't work as well.

What can I check?

This is my testparm:
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[netlogon]"
Processing section "[profiles]"
Processing section "[profdata]"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[contabilita]"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_DOMAIN_PDC
	workgroup = MYDOMAINNAME
	server string = %h PDC (%v)
	interfaces = eth0, lo
	bind interfaces only = Yes
	passdb backend = ldapsam:ldap://localhost
	guest account = guest
	name resolve order = wins host dns bcast
	add user script = /bin/netuseradd -a -m '%u'
	delete user script = /bin/netuserdel '%u'
	add group script = /bin/netgroupadd -a -p '%g'
	delete group script = /bin/netgroupdel '%g'
	add user to group script = /bin/netgroupmod -m '%u' '%g'
	delete user from group script = /bin/netgroupmod -x '%u' '%g'
	set primary group script = /bin/netusermod -g '%g' '%u'
	add machine script = /bin/netuseradd -w '%u'
	logon script = logon.cmd
	logon path = \\\profiles\%U
	logon home = \\\%U
	domain logons = Yes
	os level = 75
	preferred master = Yes
	domain master = Yes
	wins support = Yes
	ldap admin dn = cn=admin,dc=domain,dc=it
	ldap group suffix = ou=Groups
	ldap idmap suffix = ou=Idmap
	ldap machine suffix = ou=Computers
	ldap passwd sync = yes
	ldap suffix = dc=domain,dc=it
	ldap ssl = no
	ldap user suffix = ou=Users
	winbind enum users = Yes
	winbind enum groups = Yes
	winbind use default domain = Yes
	admin users = root, "@MYDOMAINNAME^Domain Admins"

	comment = Home Directories
	valid users = %S
	read only = No
	root preexec = /etc/samba/scripts/mk_sambadir "/home/%u" "%u" "%g"

	comment = Network Logon Service
	path = /dati/samba/netlogon
	guest ok = Yes
	browseable = No
	browsable = No
	locking = No

	comment = Users profiles
	path = /dati/samba/profiles
	read only = No
	browseable = No
	browsable = No

	comment = Profile Data Share
	path = /var/lib/samba/profdata
	read only = No
	profile acls = Yes
	browseable = No
	browsable = No

	comment = All Printers
	path = /tmp
	create mask = 0700
	printable = Yes
	browseable = No
	browsable = No

	comment = Printer Drivers
	path = /var/lib/samba/printers

	comment = contabilita
	path = /dati/contabilita
	read only = No
	create mask = 0775
	force create mode = 0775
	directory mask = 0770
	force directory mode = 06775
	hide unreadable = Yes
	vfs objects = recycle
	recycle:repository = .cestino/%U
	recycle:touch_mtime = yes
	recycle:touch = yes
	recycle:directory_mode = 770
	recycle:noversions = *.doc|*.xls|*.ppt
	recycle:excludedir = 
	recycle:exclude = *.tmp|*.temp|*.o|*.obj|~$*|*.~??|~*.tmp
	recycle:maxsize = 50000000
	recycle:versions = yes
	recycle:keeptree = yes

Lorenzo Milesi - lorenzo.milesi at yetopen.it

YetOpen S.r.l. - http://www.yetopen.it/

More information about the samba mailing list