[Samba] samba permission denied after a kernel build

Michael Wood esiotrot at gmail.com
Sun Dec 1 01:27:55 MST 2013

Maybe this will help:


Also maybe you need a newer version of cifs-utils to work wigh the newer

Michael Wood

On 26 Nov 2013 7:49 PM, "Paul Enright" <paul at enrights.net> wrote:
> I have a ISO that I have remaster for some custom recovery procedures. I
> tried using the same rootfs (initrd) that works with kernel 3.1.2 on older
> hardware, but not newer. So I downloaded the 3.12.1 kernel tree to a
> 10 server. Builded the 3.12.1 kernel and tried it with the older rootfs.
> Now the new hardware and old hardware will fire up the network, but when I
> try and mount.cifs I get a permission denied error (-13) I started pxe
> loading the kernel and root file system so I can switch between the
> combinations easily. Of course I can not test old kernel on new hardware
> since the old kernel does not have the needed network drivers. but on the
> old hardware, if I load the 3.1.3 kernel and same rootfs the mount.cifs
> works.
> Am I missing some option in the "make menuconfig"?
> Any thoughts on fixing it?
> Did my setup of the question make sense?
> --
> Thanks,
> Paul
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list