[Samba] Python UCS2 vs UCS4 issue on latest git: ImportError: ....undefined symbol: PyUnicodeUCS2_Decode (SOLVED!)

Phil Quesinberry philq at qsystemsengineering.com
Sun Apr 14 14:13:33 MDT 2013

OMG... I fixed it.

Since libgnutls.so.26 was in /usr/local/lib and not in /usr/local/samba/lib,
I added a file called gnutls.conf to /etc/ld.conf.d/ with the following

I then did an ldconfig and now it seems to work!  System programs like yum
which appear to rely on the older version of Python work just fine.

Let me know if you need more info or want me to try any additional testing
to try and extract more detailed information to potentially improve the
installation process or otherwise keep this from happening to other users. 
After this experience, I'm happy to play a small part in helping others
avoid this sort of misery.

Well, I just learned something.  And a word of advice to anyone else reading
this thread... don't mess with your Python installation unless you know what
you're doing.  ..and if you're contemplating messing with your Python
installation... you probably don't.   :)

Many, MANY thanks Andrew for taking your valuable time to try and help me
get this running as well as everyone else who chimed in with comments trying
to help.

Best regards,

- Phil

View this message in context: http://samba.2283325.n4.nabble.com/Re-Python-UCS2-vs-UCS4-issue-on-latest-git-ImportError-undefined-symbol-PyUnicodeUCS2-Decode-NOT-SOL-tp4646314p4646745.html
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list