[Samba] Windows 8 Pro no domain logon possible

Roland Schwingel roland.schwingel at onevision.com
Thu Sep 20 03:30:23 MDT 2012


Some days ago I installed windows 8 pro from MSDN on one of my machines. 
I got a serious problem with it. I cannot logon as domain user.

I first tried joining my domain from win8 with an unchanged win8 
installation. This did fail. Afterwards I applied the usual windows 7 
registry patches to allow a samba domain join and rebooted. Afterwards I 
could join my domain with no trouble. I rebooted and tried to log in as 
domain user. No chance. It fails.

In the windows eventviewer I can find a message from Netlogon about a 
missing RPC server and that it cannot create a secure session with the 
domain controller (translated from german).

In the samba log I can find this:
[2012/09/20 10:03:56.934783,  0] 
   _netr_ServerAuthenticate3: netlogon_creds_server_check failed. 
Rejecting auth request from client DEVINTEL-2 machine account DEVINTEL-2$

My PDC is running samba 3.6.6 with smb2 enabled. My samba is ldap 
backed. The trust account looks as it should when I look into the

I already had the same problems with the release preview of windows 8 
some weeks ago (at that time my pdc was still 3.6.3). All versions of 
windows 8 before the release preview did work without trouble.

Does anyone have the same problems?
Has anyone already got a working windows 8 pro in a domain?

This is very annoying. Any help is greatly appreciated.


More information about the samba mailing list