[Samba] Mounting DOSBOX on a remote share

czezz czezz at o2.pl
Fri Sep 14 17:30:23 MDT 2012

Hello again,
it seems that it is somehow related to SAMBA.
If I add options "noserverino" and "directio" to smbmount then problem is partly solved.
I share an old dBase/Clipper program with Samba.
This program is used by multiple WinXP,Vista hosts simultaneously.
DOSbox can see CIFS/SMB share. It can run the program and use database. New entries added to DB by other hosts appears also at Dosbox (that didnt happend without "directio").
However, if I create eg. a simple txt file, DOSbox will not see that file (at lease cant list it).
But it can display content of that txt file.
Any ideas why it is like this ?
Dnia 13 września 2012 15:01 czezz <czezz at o2.pl> napisał(a):
It is probably not strictly related to SAMBA itself but let me try to ask you for advice.
Using smbmount I have mounted one of smb/cifs share to /root/test.
This share has RW access and no authentication is required.
Now, under DOSBox, whenever I try to mount /root/test I get this error
(command sent under DOSBox: mount c /root/test).
 Directory /root/test doesn't exist.
Any other directories, which are not smb/cifs I can easly mount.
Moreover: I have tried to do this same operation under WinXP and it just works.
Does anyone know how to fix it or what is wrong ?
Best regards,

More information about the samba mailing list