[Samba] Custom SAMBA4/OpenChage ZEG applicance

John Russell jb.fresh at gmail.com
Mon Sep 10 10:42:11 MDT 2012

Decided to change distributions and use Debian, but now I'm having early
I am using Debian 6.0.5 Squeeze
OpenChange from svn co -r 4145

First I had to modify the "installsamba4.sh" file and remove any references
to "--disable-tdb2"
That will allow "make samba" to run successfully. Next I run:
 ./autogen.sh && ./configure --prefix=/usr/local/samba
No issues here but when I run "make" I get the following error several
minutes into the compiling process:

Linking sample application bin/libmapixx-test
/usr/local/samba/lib/private/libkrb5-samba4.so.26: undefined reference to
`rep_strerror_r at SAMBA_4.0.0BETA5'
collect2: ld returned 1 exit status
make: *** [bin/libmapixx-test] Error 1

I have a feeling it has something to do with a reference in a script to the
SAMBA version, but the wrong ascii character is being used for quotes.
Notice `rep_strerror_r at SAMBA_4.0.0BETA5' better written as char(96)
rep_strerror_r at SAMBA_4.0.0BETA5char(39). Let me know if I am even in the
ballpark with this one or if anyone else has run into this issue. Thanks

On Tue, Apr 17, 2012 at 1:20 PM, John Russell <jb.fresh at gmail.com> wrote:

> Question following HowTo build your own OpenChange/SOGo appliance:
> I have been building my own SAMBA4/OpenChange appliance *MOSTLY*following the instructions at
> http://tracker.openchange.org/projects/openchange/wiki/HowTo_build_your_own_OpenChangeSOGo_appliance
> .
> I am using Ubuntu-Server 12.04 LTS (Precise Pangolin)
> precise-server-amd64.iso
> OpenChange from svn co -r 3923
> https://svn.openchange.org/openchange/branches/sogo
> SAMBA4 - Samba-4.0.0Alpha18
> At the step titled "Configure DNS service"
> # cd /etc/bind
> # mkdir samba
> # cp /usr/local/samba/private/named.* samba/
> # cp –rfi /usr/local/samba/private/dns samba/
> my named.* files are actually in "/usr/local/samba/share/setup/" (no big
> deal)
> logically I would assume my dns files would be in
> "/usr/local/samba/share/setup/dns" but no cookie :(
> Find reveals:
> find / -name "dns"
> /openchange/sogo/samba4/lib/dnspython/dns
> /openchange/sogo/samba4/libcli/dns
> /openchange/sogo/samba4/bin/default/libcli/dns
> /openchange/sogo/samba4/bin/default/source4/dsdb/dns
> /openchange/sogo/samba4/source4/selftest/provisions/alpha13/private/dns
> /openchange/sogo/samba4/source4/dsdb/dns
> /usr/share/pyshared/dns
> /usr/lib/python2.7/dist-packages/dns
> /usr/src/linux-headers-3.2.0-23-generic/include/config/ceph/lib/use/dns
> /usr/src/linux-headers-3.2.0-23-generic/include/config/dns
> Does anyone know the correct dns file or directory to copy to the bind
> directory?
> Thanks

"It's better to be boldly decisive and risk being wrong than to agonize at
length and be right too late."
Marilyn Moats Kennedy

More information about the samba mailing list