[Samba] Compiling samba4 hangs at [1815/3978] Compiling librpc/ndr/ndr_basic.c

Mario Codeniera mario.codeniera at gmail.com
Wed Oct 24 22:02:20 MDT 2012

On Thu, Oct 25, 2012 at 2:40 PM, Andrew Bartlett <abartlet at samba.org> wrote:

> On Thu, 2012-10-25 at 14:31 +1300, Mario Codeniera wrote:
> > Hi,
> >
> > It was the same thing that I encountered it will stop on that
> > "librpc/ndr/ndr_basic.c" in which I posted before. But using a 64bit
> CentOS
> > 6.3, no problems encountered as I tried it as I curious with the
> problems,
> > but in 32 bit it will hang up in which the server currently running and
> > can't upgrade to 64bit as of the moment.
> >
> > Another observation when RC3 was released, it compiled smoothly without
> any
> > problems encountered. After which you can't recompile it, unless if you
> > reinstall the CentOS (which I did, just to test it). That's why I didn't
> > delete my compiled samba4. My assumptions there is an incompatibility
> > issues (not sure with it), but why it works when RC3 was released?
> >
> > I also bit confused of this unusual problem.
> Without wiping the OS, does the problem happen if you build in a new
> tree?
> Does removing the ccache package help?
> Andrew Bartlett
> --
> Andrew Bartlett                                http://samba.org/~abartlet/
> Authentication Developer, Samba Team           http://samba.org
I used to create a new tree but still doesn't solved, and ccache is not
installed by default even I installed it. No luck.

What I observed upon compilation it display a warning before compiling the
source4/torture/ and  default/librpc/ directories , hope it doesn't affects.

../source4/torture/ndr/samr.c: In function
../source4/torture/ndr/samr.c:297: warning: integer constant is too
large for ‘long’ type

More information about the samba mailing list