[Samba] Windows 7 clients not joining domain with Samba PDC

Daniel Foster daniel at 34sp.com
Thu Nov 22 08:53:49 MST 2012

Yes I searched, I tried fixes, I pulled my hair out and finally gave in.

New Windows 7 desktop trying to join a domain happily service XP clients 
from Samba 3.5.10 on Centos 6.3.

I've applied the registry fix from 
and rebooted, no joy.

I've tried nikonz' changes from 
http://www.tomshardware.com/forum/75-63-windows-samba-issue with no joy.

Each time I try to have the machine join the domain, I get the following 
in the machine specific error log:

[2012/11/22 15:28:45.189030,  0] lib/util_sock.c:474(read_fd_with_timeout)
[2012/11/22 15:28:45.189331,  0] 
   getpeername failed. Error was Transport endpoint is not connected
   read_fd_with_timeout: client read error = Connection reset by 

followed by the message:

"The join operation was not successful. This could be because an 
existing computer account having the name "MACHINENAME" was previously 
created using a different set of credentials. Use a different computer 
name, or contact your administrator to remove any stale conflicting 
account.  The error was:

Access is denied."

How can I get Windows 7 to play nice and join in with the domain?

Daniel Foster
Technical Director

More information about the samba mailing list