[Samba] MS Sharepoint 2010 configuration fails with Samba/Openldap PDC

Andreas Krupp andreaskrupp at akrupp.ch
Wed Nov 21 06:16:23 MST 2012

Hey Andrew!!!

Great hint with Samba4! For the moment it works like a charm - not to mention the really great tutorials on how installing it.
Overall, the Sharepoint 2010 installation & configuration wizard completed successfully.

For the records, here is what I used:

-> Domain Controller CentoOS 6.3 x64, installed "minimal"
I did some basic stuff first: Admin user, network configuration
Then added the samba4 system requirements: https://wiki.samba.org/index.php/Samba_4/OS_Requirements
I had to add the "bind-utils" manually to be able to use the "host" command for DNS testing, and "git" to download the samba4 package
Then I followed the tutorial here for a fresh installation: https://wiki.samba.org/index.php/Samba4/HOWTO

I used the integrated DNS service + configured Kerberos.

Joining the SQL Server and the Application Server to the domain worked perfectly (Windows Server 2008 R2 sp1)

Created a service account on the samba4 domain and added it to the administrators group on both server + configured the SQL Server Services with the service account.

And then the Sharepoint Wizard worked just fine :)
This is by far the best samba experience I had so far!!!!

Cheers & best,

-----Original Message-----
From: Andrew Bartlett [mailto:abartlet at samba.org] 
Sent: mardi 20 novembre 2012 22:49
To: Andreas Krupp
Cc: samba at lists.samba.org
Subject: Re: [Samba] MS Sharepoint 2010 configuration fails with Samba/Openldap PDC

On Tue, 2012-11-20 at 19:12 +0100, Andreas Krupp wrote:
> Hello,
> I hope this is the right mailing list for troubleshooting.
> My environment is:
> -CentOs 6.3 x64
> -Samba as PDC
> -OpenLdap
> -Bind
> I followed this very nice tutorial to set-up the environment as PDC:
> http://www.server-world.info/en/note?os=CentOS_6
> <http://www.server-world.info/en/note?os=CentOS_6&p=samba&f=4> 
> &p=samba&f=4
> And actually almost everything is working. I can add Windows Server 
> 2008 R2 to the domain, use users and service accounts from samba/ldap 
> and e.g. run SQL Server over such a service account.
> However, my Sharepoint 2010 Configuration Wizard fails every time I am 
> trying to configure Sharepoint. The normal resolution for this problem 
> is to do the installation while the Sharepoint Server is connected to the Domain.
> In my case, I am connected to the domain but it does not work. The 
> error message from sharepoint is:

> The ".GetDomainControllerToSearch" function that does not get the 
> right result made me dig into the LDAP requests that the Sharepoint 
> Installation is sending to the PDC. And I could isolate a couple of 
> requests with 0 results that I thought were causing the trouble.
> After I added the group "Domain Controllers" to the LDAP, added the 
> PDC to that group and made several DNS modification to match those of 
> a Windows PDC. I still cannot get rid of the error. So here are the 
> remaining LDAP queries without response:

If sharepoint is expecting an AD DC, then you really have no option but to run an AD DC.  See our wiki at https://wiki.samba.org/index.php/Samba4/samba3upgrade/HOWTO for an explanation of the process of upgrading to Samba 4.0 as an AD DC.

An OpenLDAP server simply won't have the right structure that sharepoint is looking for.

Andrew Bartlett
Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org

More information about the samba mailing list