[Samba] Trouble with mount.cifs while smbclient works (Ubuntu 12.04)

Jeff Layton jlayton at samba.org
Sat May 19 06:37:49 MDT 2012

On Fri, 18 May 2012 16:32:29 -0500
<Scott_Purcell at Dell.com> wrote:

> Yes, I think that has been the normal behavior since our data was moved to this device.  I assumed it was due to filesystem permissions -- that I don't have read access to the root level of the share, but do have r/w access to the /training/ directory below it.
> Using smbclient, get "NT_STATUS_ACCESS_DENIED" when I try:
> 	ls 
> 	ls training
> 	ls /training
> 	ls /training/
> but if I cd to training, I can list its contents.
> BTW, 
> I've tried appending the path in my mount command as well and mount.cifs still doesn't handle it:

Known problem since the superblock sharing patches went in. cifs.ko
needs to establish a dentry and inode for the root of the share and
then walks down to the "prefixpath" for the mount. Unfortunately if you
don't have access to any point along that path, the mount will fail.

There have been a couple of proposals to fix it, but they've had their
own problems. What probably needs to happen is to do something like
what NFS does in its superblock sharing model. Allow several trees of
dentries within a superblock and only connect them later if we happen
to stumble across the right entry. See commit 54ceac45159 for an
explanation of the model NFS uses for this.

Jeff Layton <jlayton at samba.org>

More information about the samba mailing list