[Samba] Trouble with mount.cifs while smbclient works (Ubuntu 12.04)

Scott_Purcell at Dell.com Scott_Purcell at Dell.com
Fri May 18 15:32:29 MDT 2012

Yes, I think that has been the normal behavior since our data was moved to this device.  I assumed it was due to filesystem permissions -- that I don't have read access to the root level of the share, but do have r/w access to the /training/ directory below it.

Using smbclient, get "NT_STATUS_ACCESS_DENIED" when I try:

	ls training
	ls /training
	ls /training/

but if I cd to training, I can list its contents.


I've tried appending the path in my mount command as well and mount.cifs still doesn't handle it:

-----Original Message-----
From: Günter Kukkukk [mailto:linux at kukkukk.com] 
Sent: Thursday, May 17, 2012 8:03 PM
To: Purcell, Scott

After connect you do a "ls training/" and get access denied, but then you
cd into that subdir and "ls" is working.
Do you _always_ see this behavior?

When you use "ls" directly after connect, do you get some error?

Cheers, Günter

More information about the samba mailing list