[Samba] mutex.tdb locking errors on Solaris 10

S.Kirk s.kirk at soton.ac.uk
Wed May 9 08:18:02 MDT 2012


On Mon, 30 Apr 2012, Kirk S. wrote:

> Morning list,
> <--snip -->
>> We have not tried the version of Samba currenlty shipping with Solaris 
>> - we've found a lot of problems with it in the past integrating with 
>> AD. As it currently stands, single sign-on works but there is a CNAME 
>> that the clients are pointing to which doesn't seem optimal but does 
>> work. I take it you're using the version shipped with Solaris - update 
>> 10 to 3.5.10 I guess?
> <--snip-->
> In a further update to this problem, I have migrated the CNAME to 
> another server that we have standing in for the 'faulty' instance. This 
> server was previously working fairly well (although SMF had restarted 
> samba at least once due to the parent smbd process crashing but no core 
> file was produced) and was not generating large numbers of error message 
> regarding locking mutex.tdb.
> Now I have migrated the CNAME, we have huge numbers of errors on the 
> temporary server.

A minor change of deleting the CNAME and replacing it with an A 
record that points at the same IP as the server uses as it's primary 
interface (wthout removing the existing A record for hostname or 
modifying the PTR record) seems to have resolved the huge numbers 
of errors locking mutex.tdb and the associated performance problems we 
were experiencing.

It doesn't sound like anyone else is experiencing this so I assume the 
only thing to do is to file a bug report? I've not tried 3.6.5 yet but I 
see it has been packaged by OpenCSW a few days ago so I may be able to try 
it on a test machine.


More information about the samba mailing list