[Samba] Kernel 3.4.6: cifs problem

Günter Kukkukk linux at kukkukk.com
Sat Jul 28 07:38:09 MDT 2012

Am Samstag, 28. Juli 2012, 08:55:00 schrieb Helmut Hullen:
> Hallo,
> I've just tried kernel 3.4.6, self compiled, with the ".config" from
> kernel 3.3.7.
> Samba version 3.5.14 (slackware)
> When I run a script with (among many other lines) the command
>   mount.cifs //$share/$src /path/to/$target \
>     -o noperm,sec=ntlmv2,$Loginparms
> (which runs without any problem under kernel 3.3.7) then I get an error
> message (some cifs problem), and the script finishes its work.
> Where should I look for more informations?
> Viele Gruesse!
> Helmut

during the rewrite of the mount options parsing the "ntlmv2"
security option got lost - will be back in the next version.

As a workaround "sec=nontlm" can be used.

This somewhat strange option name will exactly do the same
as "sec=ntlmv2".

Cheers, Günter

see also: http://permalink.gmane.org/gmane.linux.kernel.cifs/6656

More information about the samba mailing list