[Samba] [Samba4] samba_dlz problem "loading configuration: already exists"

Andreas Schweizer aschweiz at mac.com
Sat Jan 7 12:02:57 MST 2012


I'm new to this list and Samba4, so may be this is a stupid question. I've installed samba4 (4.0.0alpha18-GIT-7b42ceb) on a server in my home LAN and have a problem with samba_dlz and bind (9.8.1-P1). 

In the zone definition file for my LAN domain, I had configured the IP addresses for several host names (e.g. printer, ...) with "A" records. This worked perfectly fine in the past (e.g. "nslookup printer" returned the IP address of my printer). After adding the following line in /etc/named.conf according to the HOWTO:

include "/usr/local/samba/private/named.conf";

...I now get an error from samba_dlz:

named: samba_dlz: Failed to configure zone 'myzone.priv'
named: loading configuration: already exists

If I comment-out my zone in /etc/named.conf, Samba4 works fine (it can even update the DNS database), but I can of course no longer access my devices, e.g. nslookup printer returns:

aschweiz ~> nslookup printer

** server can't find printer: NXDOMAIN

What I already tried was to add my devices in dns_update_list, e.g. by adding a line:

A    printer

However, then I get an error message when starting samba: "Failed DNS update - NT_STATUS_ACCESS_DENIED".

Can anybody help me with this? How to add devices to the zone that Samba creates in the DNS server?

Thank you,

More information about the samba mailing list