[Samba] Set primary group of file on samba share from windows

Hubert Kario hka at qbs.com.pl
Thu Jan 5 15:36:58 MST 2012

Hi all!

I want to use 'acl group control' setting to delegate privileges to specific 

Unfortunately, I'm unable to set the primary group using windows file 
permissions dialog, I can only add and remove ACL groups.

I tried to do this by removing all groups but one from Windows. This doesn't 
work: the primary group has all privs removed and the extra group is still in 
ACLs only.

Then I tried to set the file/directory owner to group from Windows, but this 
was met with a permission denied and a following log message:

[2012/01/05 21:13:03.349734,  3] smbd/nttrans.c:1899
  call_nt_transact_set_security_desc: file = projects/project A/New folder, 
sent 0x1
[2012/01/05 21:13:03.349774,  3] smbd/posix_acls.c:1208(unpack_nt_owners)
  unpack_nt_owners: unable to validate owner sid for 
[2012/01/05 21:13:03.349804,  3] smbd/error.c:80(error_packet_set)
  error packet at smbd/nttrans.c(1909) cmd=160 (SMBnttrans) 

Is setting the primary group possible, or do I have to do it from shell?

Hubert Kario
QBS - Quality Business Software
02-656 Warszawa, ul. Ksawerów 30/85
tel. +48 (22) 646-61-51, 646-74-24

More information about the samba mailing list