[Samba] Error in provisioning Samba4 Alpha 18 from git

Mathias Friman mathias.friman at knorca.se
Thu Feb 2 13:45:32 MST 2012


I have a problem. The prerequisites are:

* Vanilla Ubuntu 10.04 install
* Followed the http://wiki.samba.org/index.php/Samba4/HOWTO 

In step 4, after running the command:

./source4/setup/provision --realm=samdom.example.com --domain=SAMDOM --adminpass=SOMEPASSWORD --server-role='domain controller'

i get the following error when the provisioning run tdbbackup from the script "bin/python/samba/provision/sambadns.py":

Looking up IPv4 addresses
Looking up IPv6 addresses
No IPv6 address will be assigned
Setting up secrets.ldb
Setting up the registry
Setting up the privileges database
Setting up idmap db
Setting up SAM db
Setting up sam.ldb partitions and settings
Setting up sam.ldb rootDSE
Pre-loading the Samba 4 and AD schema
Adding DomainDN: DC=samdom,DC=example,DC=com
Adding configuration container
Setting up sam.ldb schema
Setting up sam.ldb configuration data
Setting up display specifiers
Adding users container
Modifying users container
Adding computers container
Modifying computers container
Setting up sam.ldb data
Setting up well known security principals
Setting up sam.ldb users and groups
Setting up self join
Adding DNS accounts
Populating CN=MicrosoftDNS,CN=System,DC=samdom,DC=example,DC=com
Creating DomainDnsZones and ForestDnsZones partitions
Populating DomainDnsZones partition
Populating ForestDnsZones partition
bin/tdbbackup: /home/administrator/source/samba-master/bin/shared/private/libtdb.so: version `SAMBA_4.0.0ALPHA18_DEVELOPERBUILD' not found (required by bin/tdbbackup)
Failed to setup database for BIND, AD based DNS cannot be used
Traceback (most recent call last):
  File "./source4/setup/provision", line 256, in <module>
    useeadb=eadb, next_rid=opts.next_rid, lp=lp)
  File "bin/python/samba/provision/__init__.py", line 1757, in provision
    am_rodc=am_rodc, lp=lp)
  File "bin/python/samba/provision/__init__.py", line 1491, in provision_fill
    targetdir=targetdir, site=DEFAULTSITE)
  File "bin/python/samba/provision/sambadns.py", line 990, in setup_ad_dns
    create_samdb_copy(samdb, logger, paths, names, domainsid, domainguid)
  File "bin/python/samba/provision/sambadns.py", line 751, in create_samdb_copy
    os.path.join(dns_dir, "sam.ldb"))
  File "bin/python/samba/provision/sambadns.py", line 688, in tdb_copy
    raise Exception("Error copying %s" % file1)
Exception: Error copying /usr/local/samba/private/sam.ldb

The file /home/administrator/source/samba-master/bin/shared/private/libtdb.so does exist.

What can/should I do? I tried this on Ubuntu 11.10 desktop as well, with the exact same result.

Kindest regards,

PS. I'm not part of the samba mailinglist. DS.

More information about the samba mailing list