[Samba] phpldapadmin and samba4

Andrew Bartlett abartlet at samba.org
Fri Dec 7 16:06:10 MST 2012

On Fri, 2012-12-07 at 11:52 -0200, Thiago Parolin wrote:
> I'm testing the Samba4 rc6 and Phpldapadmin 1.2.3 in Debian Wheezy.
> All is working, but phpldapadmin..
> When i click to edit any item on the left menu, the "retrieving DN" message
> is displayed for some seconds and after this, other message is displayed:
> "There was a problem with the request."
> Looking at the logs:
> /var/log/apache2/error.log
> PHP Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried
> to allocate 270270731 bytes) in Unknown on line 0,...
> I have tried many things to fix this: changing memory limit (from 128M to
> 256M, 512M, 1024M) and max_execution_time (from 30 to 60, 120, 160) in
> php.ini, changing phpldapadmin versions (1.2.2, but the errors are
> always the same.
> Did anyone ever seen this before?

We recently removed the pre-generated configuration for phpldapadmin
because nobody was testing the combination.  I don't know what the issue
is, but it is not a combination we actively support any more (nobody
noticed for ages that the config file we generated was not compatible
with modern versions, for example).

Andrew Bartlett

Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org

More information about the samba mailing list