[Samba] Cannot see usb external drive shares

Gaiseric Vandal gaiseric.vandal at gmail.com
Tue Apr 24 06:49:00 MDT 2012

Have you tried disabling selinux enforcing  to at least verify that
selinux is a factor?   I have found selinux by default restricts apache
from accessing non-root partitions even on internal drives.     Also,
there should be a /var/log/secure log that may be showing the selinux
"errors."    What file system is used on the external drive?

On 04/23/12 21:06, ED B wrote:
> I am running fedora 15 with default selinux enforcing.  I have set up the configuration for several users who can access their home directories but none of the shares on he external drive.  I have run the setsebool commands listed in the smb.conf file.  I have run the testparm command and no issues are identified.  Here is one of the configured share directories in smb.conf:
> [Music]	path = /mnt/raid1/external_storage1/Music	valid users = administrator, user1	read only = No	browseable = No
> I tried running smbd -D -d 10  and the only output in the log files that seems to complain is:
> client.logreceive_smb_raw_talloc failed for client read error = NT_STATUS_END_OF_FILEServer exit (failed to receive smb request)
> smbd.logDeleting serverid.tdb record failed: NT_STATUS_NOT_FOUND
> No clue on what that means. Google is not helping.

More information about the samba mailing list