[Samba] After Samba upgrade, trust relationship always fails

Eric Evans eje4 at cornell.edu
Mon Apr 16 08:14:01 MDT 2012


For a long time I've been running Samba 3.5.10 as a domain controller on RH Enterprise 5, with Windows 7 clients.  Everything has worked fine.  But since I recently upgraded to Samba 3.6.4, I have a persistent problem with users not being able to login to the client machines successfully because they get the "Trust relationship has failed" message.  I can join the client machines to the domain without any problem, but the client logins always fail.  The smbd log file shows repeated instances of the "netlogon_creds_server_check failed" message.

I've gone through all of the troubleshooting procedures recommended in the O'Reilly Samba book and they all checked out.  I've also tried deleting and recreating the Samba machine accounts, and also rejoining the clients to the domain.  I'm at the point where I've run out of ideas.  Can anyone suggest anything further that I could try?

Thanks very much,

More information about the samba mailing list