[Samba] Samba fails

McGranahan, Jamen jamen.mcgranahan at Vanderbilt.Edu
Tue Sep 20 11:59:18 MDT 2011

We are running Samba 3.5.8 on a Solaris 10 box and created several shares on our server so that people can access certain files/folders via the Active Directory (so we are also using winbindd). This worked well for a couple of years until recently - now, we are not able to access any of our shares. When we try, samba crashes (though nmbd & winbind do not). I've gone through several tests:

testparm -> everything is fine here

wbinfo -u, wbinfo -g, getent passwd USERID, getent group GROUPID -> all are successful

When I try smbclient, connecting to the server itself, I get "tree connect failed: NT_STATUS_CONNECTION_INVALID". On the Samba listserv, there was a post just like this on 8/3/2011, but no solution was offered (other than please send a debug level 10 log - don't know if this ever happened). I tried the recommendation on this page - http://www.unixresources.net/linux/lf/56/archive/00/00/05/78/57864.html - changing "valid users" to just "users", and got the same result. I'm not really sure what else to try, but I sure would appreciate any suggestions or recommendations. Thank you!

Jamen McGranahan
Systems Services Librarian
Vanderbilt University Library

# smbclient //acorn6/test -U mcgranj -d=3
lp_load_ex: refreshing parameters
Initialising global parameters
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
params.c:pm_process() - Processing configuration file "/etc/samba/smb.conf"
Processing section "[global]"
added interface e1000g1265000 ip= bcast= netmask=
added interface e1000g0 ip= bcast= netmask=
Client started (version 3.5.8).
Enter mcgranj's password:
resolve_wins: Attempting wins lookup for name acorn6<0x20>
resolve_wins: using WINS server and tag '*'
Got a positive name query response from ( )
Connecting to at port 445
Doing spnego session setup (blob length=128)
got OID=1.2.840.113554.1.2.2
got OID=1.2.840.48018.1.2.2
got OID=
got principal=cifs/acorn6.library.vanderbilt.edu at DS.VANDERBILT.EDU<mailto:principal=cifs/acorn6.library.vanderbilt.edu at DS.VANDERBILT.EDU>
Got challenge flags:
Got NTLMSSP neg_flags=0x60898215
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60088215
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60088215
Domain=[VANDERBILT] OS=[Unix] Server=[Samba 3.5.8]

More information about the samba mailing list