[Samba] Winbind and resolution of groups/usernames

Florian Götz f.goetz at hs-mannheim.de
Thu Sep 1 01:41:34 MDT 2011

Hi everybody,

I´m trying to get a Server (OpenSUSE 11.4 64bit with samba 3.5.7) to act 
as a domain member in a Samba Domain (SLES 10 32bit with Samba 3.0.28).
The server has been successfully added to the domain via "net rpc join - 
S <pdc> -U root "

/etc/nsswitch.conf has been modified like:
passwd:  files winbind
groups: files winbind

/lib64/libnss_winbind.so.2 and /lib/libnss_winbind.so.2 are in place.

Winbind-Config of the "client":

         password server = *
         winbind separator = +
         winbind use default domain = yes
         winbind enum users = yes
         winbind enum groups = yes
         winbind cache time = 10
         idmap uid = 10000-30000
         idmap gid = 10000-20000
         template shell = /bin/bash
         template homedir = /home/%u

wbinfo -g shows all of our ~8500 Users, wbinfo -g all of our ~ 100 groups

Now if I´m trying to use "getent passwd" I get results of about 1200 to 
1500 users, "getent groups" only shows the local groups.
I tried almost every howto I found via the net, but I won´t work :(
I even tried it with a fresh install of Debian, same problem. Rather 
sure it´s a configuration problem, but I don´t have anymore clues where 
to take a look.

Anyone out there with an idea where to look for failures?

Best regards
Florian Götz

Mit freundlichen Grüßen
Florian Götz

More information about the samba mailing list