[Samba] samba with nfs mount in "path" and MS Office App's

free4me at gmx.ch free4me at gmx.ch
Thu Oct 13 05:38:44 MDT 2011


Thanks for the input so far

So far i've tried following:


strict locking = yes
oplocks = no

in Smb.conf. This didnt work. Then i've tried to mount the nfs with "nolock" Option (but without above samba locking parameters). Problems still persists. I've need now to test some combinations of these settings.

I've also talked to a Netapp Engineer. The NFS Mount points to a FAS3140 Cluster with Ontap 7.3.2 on it. The volume with the data which is referred in path of Samba config is a qtree. There are three different types of "qtree" security settings on Netapp Files: mixed,unix,windows. It might have something to do with the choosen security style. Netapp itself is using NFS3 (nfs4 can be turned on optionally): http://www.netapp.com/us/communities/tech-ontap/nfsv4-0408.html

I've also tried some setfacl commands on the nfs mount and it said: Operation not supported...

So i've got several possible reasons for the problem now:

- samba config (locking parameters)
- nfs mount options (locking parameters)
- Right issues (acl or similiar)
- qtree securtity style on Netapp

I will test some things and let you know....i will start with the netapp qtree issues...

Best Regards
NEU: FreePhone - 0ct/min Handyspartarif mit Geld-zurück-Garantie!		
Jetzt informieren: http://www.gmx.net/de/go/freephone

More information about the samba mailing list