[Samba] Issue with compile of 3.5.12 -- krb related

James Chase james at chasecomputers.net
Wed Nov 9 05:17:40 MST 2011

>> =
>> I was missing the KRB5 line so I installed krb5-devel (centos 5.7) and
>> then re-configured. During the make command I now get the following error:
>> cifs.upcall.c:(.text+0x360): undefined reference to
>> `smb_krb5_principal_get_realm'
>> cifs.upcall.c:(.text+0x3d3): undefined reference to `smb_krb5_unparse_name'
>> collect2: ld returned 1 exit status
>> make: *** [bin/cifs.upcall] Error 1
>> I first installed every krb5 package I could find (didn't fix the
>> compile errors) and then I tried disabling this cifsupcall feature but
>> then got the same errors using testparm. So maybe this feature  is
>> required for the 'ads' option and 'realm' parameter. Arg -- does this
>> indicate my krb5 libraries are too old and missing some new function?
> Did you make clean?
Doh! That fixed it =o)

Fixed the errors from testparm, though now wbinfo doesn't work...

[root at sambatest samba]# bin/wbinfo -u
Error looking up domain users

Grrr. Will have to mess around with it more later
> Andrew Bartlett

More information about the samba mailing list