[Samba] build samba on solaris 10 fails on libwbclient

Richard Gillman R.Gillman at nerc.ac.uk
Mon May 16 04:42:45 MDT 2011


I'm trying to build Samba on Solaris 10 sparc.

./autogen.sh completes but with warnings such as

samba4.m4:6: warning: file `../m4/check_python.m4' included several times
../lib/util/xattr.m4:9: warning: AC_CACHE_VAL(smb_attr_cv_xattr_add_opt, 
...): suspicious cache-id, must contain _cv_ to be cached
../lib/util/xattr.m4:9: the top level
samba4.m4:83: warning: file `../lib/tdb/libtdb.m4' included several times
../source4/build/m4/public.m4:70: SMB_EXT_LIB_FROM_PKGCONFIG is expanded 
from...samba4.m4:83: the top level
../lib/tevent/samba.m4:3: warning: file `../lib/tevent/libtevent.m4' 
included several times
../lib/tevent/samba.m4:3: the top level

./configure --prefix=/nerc/packages/samba/3.5.7  --with-libtalloc=no 

(I had to build talloc and tdb seperately.)

The make stage fails

creating /users/itss/rgi/samba/samba-3.5.7/source3/exports/libwbclient.syms
Linking shared library bin/libwbclient.so.0
/nerc/packages/gcc/4.4.3/5.10/bin/ld: cannot open linker script file 
/users/itss/rgi/samba/samba-3.5.7/source3/exports/libwbclient.so.0: No 
such file or directory
collect2: ld returned 1 exit status
make: *** [bin/libwbclient.so.0] Error 1
tolka source3 $

gcc is

tolka source3 $ gcc -v
Using built-in specs.
Target: sparc-sun-solaris2.10
Configured with: ../gcc-4.4.3/configure 
--prefix=/nerc/packages/gcc/4.4.3/5.10 --with-gnu-as 
--with-as=/nerc/packages/gcc/4.4.3/5.10/bin/as --with-gnu-ld 
--enable-languages=c++,fortran --with-gmp=/nerc/packages/gcc/4.4.3/5.10 
Thread model: posix
gcc version 4.4.3 (GCC)
tolka source3 $

PATH is cut-down so I pick up GNU tools ld and make, rather than Solaris 
tolka source3 $ echo $PATH
tolka source3 $

tolka source3 $ which make
tolka source3 $ make -v
GNU Make 3.81
Copyright (C) 2006  Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A

This program built for sparc-sun-solaris2.9
tolka source3 $

tolka source3 $ ld -v
GNU ld (GNU Binutils) 2.20
tolka source3 $

tolka source3 $ echo $CC
tolka source3 $ echo $LD_LIBRARY_PATH
tolka source3 $ echo  $LD_RUN_PATH
tolka source3 $ echo $LDFLAGS
-L/nerc/packages/samba/3.5.7/lib -R/nerc/packages/samba/3.5.7/lib
tolka source3 $

I've tried looking for LD=ld in the configure file as suggested in an 
email May 2010, it doesn't occur. I've tried editing Makefile, add -fPIC 
-shared  -lthread -lintl as suggested in the same email. No luck.

Anybody got any suggestions?

tia, Dick

Richard Gillman
IST UNIX Systems Group, Maclean Building, Wallingford OX10 8BB
Tel: 01491 - 692 339 (outside UK: +44 1491 692339)
Fax: 01491 - 692 424

More information about the samba mailing list