[Samba] Samba authentication problem

Xamindar junkxamindar at gmail.com
Thu Mar 24 14:00:51 MDT 2011

Hi, I have asked around in other forums but no one seems to know why
this doesn't work.

I have a backup server with samba on it and am trying to set it up to
only allow write access when a user authenticates but to allow reading
from anyone (guest). At this time I have guest disabled and a minimal
config set up as shown below to try to narrow down the problem.

I have added the user "xamindar" using smbpasswd on the server. I then
tried to mount the backup share from another machine with the following
mount -t cifs //chiroru/backup /mnt/temp -o username=xamindar

But I keep getting the following response:
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Can anyone tell me what I am doing wrong here? I am sure I have missed
something. It is possible to authenticate per share with share level
security is it not? I just can't get authentication to work no matter
what I have tried on this machine. With guest enabled it will just use
the guest account and that works fine.
Thanks for any help, I am pulling my hair out here.

        server string = Backup and Multimedia server
        security = SHARE
        smb passwd file = /etc/samba/private/passdb.tdb
        load printers = No
        disable spoolss = Yes
        show add printer wizard = No
        write list = xamindar
        printing = bsd
        print command = lpr -r -P'%p' %s
        lpq command = lpq -P'%p'
        lprm command = lprm -P'%p' %j
        map hidden = Yes
        map system = Yes

        path = /mnt/user/backup


More information about the samba mailing list