[Samba] SAMBA4 and Solaris 10 X86

Gaiseric Vandal gaiseric.vandal at gmail.com
Mon Mar 7 13:34:49 MST 2011

I  have not tried Samba  4 on Solaris.

However, I found compiling Samba 3.4.x on Solaris to be quite 
challenging.  I had  to use GCC from SunFreeware.  I also have to 
install additional packages from Sunfreeware including  libtool, 
libiconv, binutils, openldap and bash.  GCC from Sun freeware tools was 
too old.  And I couldn't get anyware with the Sun CC compiler.

Finally,  the Solaris version of ld (/usr/ccs/bin/ld) is too old but 
Sunfreeware GCC was compiled with it so

# mv /usr/ccs/bin/ld /usr/ccs/bin/ld.sun
# ln -s /usr/local/bin/ld /usr/ccs/bin/ld

(I am sure other people may say that relinking ld is a terrible thing to 
do but it was the only way I could make this work.)

Some commands (e.g. bash or swing) may exist in /usr/bin but the 
compiler will expect them in /usr/local/bin so you may need some symlinks.

I also had to set compiler flags to make sure the compiler used OpenLDAP 
from sunfreeware and not sun ldap.

CPPFLAGS="-I /usr/local/include -I/usr/local/ssl/include -I/usr/include"
CPPFLAGS="-I /usr/local/samba-3.4.8-x32/include $CPPFLAGS"
LDFLAGS="-L/usr/local/ssl/lib -R/usr/local/ssl/lib \
  -L/usr/local/lib -R/usr/local/lib -L/usr/lib -R/usr/lib"
-R/usr/local/samba-3.4.8-x32/lib $LDFLAGS"
export LDFLAGS
export PATH

Unfortunately Sunfreeware GCC seems to be 32-bit (at least for the intel 
platform) and not 64-bit.

On 03/04/2011 08:41 AM, Ayman Tahboub wrote:
> hello,
> I have been trying to build/get SAMBA4 alpha13/alpha11
> to build on Solaris 10 Update 8 X86. I have tried to use the ./autogen-waf and the other ./autogen
> and following the procedure ./configure(.developer) seems to conclude correctly,
> however the actual make and make install seems to fail.
> I need to make sure first, is Samba4 supported on Solaris?
> thanks
> /ayman

More information about the samba mailing list