[Samba] Samba vs Linux file permissions

John Maher john at chem.umass.edu
Wed Jun 8 14:04:14 MDT 2011

Hash: SHA1

On 06/03/2011 03:55 PM, Robert W. Smith wrote:


> Unfortunately I do not see this as a simple mis-configuration of your
> server at this point. The error is being emitted after the smbd/open.c
> call to try and open the file. It errors out on trying to open the file
> for renaming. 

The problem no longer exists. I cannot actually say that I "solved" it,
but the best I can say is that it no longer presents itself. Here is
what happened:

One thing I did not mention (I didn't want to introduce oddities that I
didn't think were related) is that when I initially installed the OS and
install samba (but had not yet configured samba authentication), my
account was able to access the one share I had configured. So I was not
using LDAP and I had not established a password using smbpasswd, but I
could access the share.  (Could PAM have been involved?) I was mystified
by this, but I do not understand samba very well, so I ignored it.

Between that initial mystifying "success" and my final "resolution" I,
of course, have been using LDAP for authentication and struggling with
these Samba vs Linux permissions issues.

Not knowing if the directive "encrypt passwords" was only used for
smbpasswd or tdbsam, I changed "encrypt passwords = true" to "false".
Restarted smbd and nscd and tried to connect to the share using my
account.  Wouldn't let me in (and I'm guessing this would be expected by
people who know more).  So I changed "encrypt passwords" back from
"false" to "true". Restart smbd and nscd. AND I CAN CONNECT TO THE SHARE!

Needless to say, I don't know why that did anything. In the event that
someone knows what that might have done, I am definitely interested.

Thanks to those who tried to help.


Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the samba mailing list