[Samba] unix fifo inaccessible via samba share

Jeremy Allison jra at samba.org
Tue Jul 19 19:02:54 MDT 2011

On Tue, Jul 19, 2011 at 04:37:58PM -0500, Charles Redditt wrote:
> Issue: unix fifo (named pipe) does not appear in share,  attempts to read
> the pipe result in "Access Denied"
> >From an XP laptop, I can open and access my samba share normally.  I can
> read all files and subdirectories in the share, but a fifo I need to read
> does not appear at all.  I have made the fifo mode 777 (world readable,
> writeable, executeable) and tried other things like setting " follow
> symlinks = yes ", "unix extensions = no" and "log level = 3", making the
> fifo name less than 8 char,  but nothing seems to help.  If I try to
> directly read from the share, from a MSDOS cmdline, with a "type
> \\server\myshare\mypipe" I get only an "Access Denied" message.
> I have been able to do this for years on other machines, specifically one
> running CentOS 5.5, smb version 3.0.33-3.29.el5_6.2
> and yes,  I can read from the fifo w/o any problem from the linux
> commandline.  I have also tried to read the fifo via smbclient but get much
> the same result (smb: \> get mypipe
> NT_STATUS_ACCESS_DENIED opening remote file \mypipe)

Yeah, this should work (it used to). Can you try with
3.5.9 (latest version) and if it doesn't log a bug please ?



More information about the samba mailing list