[Samba] Problem using smbusers with samba on AIX 5.2 TL11SP1 system

GALVAN, Jean-Pierre Jean-Pierre.GALVAN at sage.com
Thu Jul 7 06:08:51 MDT 2011

Yes I did.
Here's my smb.conf file (I removed the shared objetcs) :
# Global parameters
        workgroup = <Removed>
        netbios name = AYDAIX05
        server string = AYDAIX05 Samba Server %v
        security = DOMAIN
        encrypt passwords = Yes
        password server = <Removed>
        username map = /etc/smbusers
        smb passwd file = /etc/smbpasswd
        log file = /opt/freeware/log/log.%m
        max log size = 50
        name resolve order = wins lmhosts bcast
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        preferred master = No
        local master = No
        domain master = No
        dns proxy = No
        wins server = <Removed>

And here's my smbusers file :
root = jpgalvan

So I'd like to see "root" home directory for my Windows user "jpgalvan"

All I see in Windows explorer is "jpgalvan" home directory


-----Message d'origine-----
De : youngjohn04 [mailto:youngjohn04 at 163.com] 
Envoyé : mercredi 6 juillet 2011 23:11
À : GALVAN, Jean-Pierre; samba at lists.samba.org
Objet : RE: [Samba] Problem using smbusers with samba on AIX 5.2 TL11SP1 system

Did you specify "username map =" option in your smb.conf file?

-----Original Message-----
From: samba-bounces at lists.samba.org [mailto:samba-bounces at lists.samba.org]
On Behalf Of GALVAN, Jean-Pierre
Sent: Wednesday, July 06, 2011 10:22 PM
To: samba at lists.samba.org
Subject: [Samba] Problem using smbusers with samba on AIX 5.2
TL11SP1 system

I don't know if you're the person who can help me.
I've got a problem with Samba on a AIX 5.3 TL11SP1 machine.

I installed and configured Samba. It worked fine. I use a DOMAIN member security mode.
The join into our domain worked well.

Any users from a Windows computer is able to access to the AIX machine.

But the only problem I have is this one :

-          The use of smbusers file is not working : when I try to specify
an other unix account for a windows user, the Windows computer sees the original account.

-          => It is just as if smbusers file was not  used ...

Can you help me on this ?
Thank you in advance.
Best regards.
Jean-Pierre GALVAN.

To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list