[Samba] ????: Could not build Samba with ADS support on Solaris 10 [SEC=UNCLASSIFIED]

Wilkinson, Alex alex.wilkinson at dsto.defence.gov.au
Wed Jul 6 21:03:06 MDT 2011

    0n Wed, Jul 06, 2011 at 11:13:54PM +0800, youngjohn04 wrote: 

    >With these environment variables set, same error appeared.
    >To avoid using bundled ldap, I removed SUNWlldap, keep only Openldap, but
    >this also made no difference.
    >I also tried using Sun Studio12, failed too.

Try something like:

1. Dependencies

   #pkg-get -i autoconf automake berkeleydb4 binutils bison common flex gcc3
   gcc3core gcc3corert gcc3g++ gcc3g++rt gcc3rt ggettext gmake gnupg gnutls
   krb5_lib krb5_lib_dev krb5_user openldap openldap_client openldap_rt sasl zlib

2. $PATH

   At a minimum: /usr/sbin:/usr/bin:/usr/ccs/bin:/opt/csw/bin:/opt/csw/gcc3/bin

3. /bin/sh variables

   Use /bin/sh when doing the build. you then need to set the following variables:
   CPPFLAGS="-I/opt/csw/include -I/usr/include -I/usr/sfw/include"
   LDFLAGS="-L/opt/csw/lib -L/usr/sfw/lib -R/opt/csw/lib:/usr/sfw/lib"

4. ld(1) hack
   This is the only hack that hack to be done. samba likes to use GNU ld and not
   the native solaris linker. This is the hack you will need:
   #mv /usr/ccs/bin/ld /usr/ccs/bin/ld.orig
   #ln -s /opt/csw/bin/gld /usr/ccs/bin/ld

5. Build

   #./configure --prefix=/export/server_apps/SAMBA_3_0_32/ --with-ldap --with-ads
   --with-krb5=/opt/csw --with-winbind --with-pam --disable-cups --with-acl-support
   --with-krb5=/opt/csw --with-shared-modules=idmap_rid
   #make install

The aforementioned recipe has worked for me many times in the past. I havent
tried recently though.


IMPORTANT: This email remains the property of the Department of Defence and is subject to the jurisdiction of section 70 of the Crimes Act 1914. If you have received this email in error, you are requested to contact the sender and delete the email.

More information about the samba mailing list