[Samba] 答复: Could not build Samba with ADS support on Solaris 10

youngjohn04 youngjohn04 at 163.com
Wed Jul 6 09:13:54 MDT 2011

Thank you Vandal.

With these environment variables set, same error appeared.

To avoid using bundled ldap, I removed SUNWlldap, keep only Openldap, but
this also made no difference.
I also tried using Sun Studio12, failed too.

Check ldap.h file:
# grep ldap_initialize /usr/local/include/ldap.h
ldap_init LDAP_P(( /* deprecated, use ldap_create or ldap_initialize */
ldap_open LDAP_P((      /* deprecated, use ldap_create or ldap_initialize */
ldap_initialize LDAP_P((

ldap_initialize really there, but it seems the configure program does not
use it.


发件人: samba-bounces at lists.samba.org [mailto:samba-bounces at lists.samba.org]
代表 Gaiseric Vandal
发送时间: 2011年7月6日 21:35
收件人: samba at lists.samba.org
主题: Re: [Samba] Could not build Samba with ADS support on Solaris 10

Samba on Solaris can be a real challenge.  Your build is probably 
picking up the Sun native(non-openldap)  ldap libraries which is why you 
have ldap support but not AD support.  AD support always requires 
kerberos but the Solaris kerberos libraries

Did you set LD_LIBRARY_PATH?

You may also need to set LDLFAGS

LDFLAGS="  -L/usr/local/lib -R/usr/local/lib -L/usr/lib -R/usr/lib"
LDFLAGS="-L/usr/local/samba-3.5.2/lib -R/usr/local/samba-3.5.2/lib $LDFLAGS"

If the compiler uses  /usr/ccs/bin/ld , you will usually have have 
compiler failures.  If  /usr/sfw/bin/gcc uses a gnu ld you may have 
better luck.

Probably the most reliable may to compile for Solaris is to use Sun 
Studio compilers and dmake.

Sun-bundled Samba 3.0.x was compiled with sun ldap, but with some extra 
netscape (?) libraries.     If you have an Oracle support contract you 
can download a Sun-provided Samba 3.5.x -  and forget compiling  it at 
all.   I do not know if they used openldap or native ldap libraries.    
I don't know if the samba patches are included in the latest patch 
cluster.  (I suspect so.)

It would be nice to have a wiki page on samba.org for building Samba 
under Solaris.

On 07/06/2011 08:33 AM, youngjohn04 wrote:

> I tried to build Samba with ADS support, I got error, messages are:
> .
> checking for ldap_initialize... no
> checking whether LDAP support is used... yes
> checking for Active Directory and krb5 support... yes
> checking for ldap_initialize... (cached) no
> configure: error: Active Directory support requires ldap_initialize
> I installed Openldap(downloaded from sunfreeware), tried the following
> commands, all resulted the same.
> $ ./configure --with-ads
> $ ./configure --with-ads CPPFLAGS="-I/usr/local/include"
> $ export CPPFLAGS="-I/usr/local/include"; ./configure --with-ads
> Samba Version: 3.4.13 or 3.5.9, Solaris 10 Sparc or x86_64.
> C compiler: /usr/sfw/bin/gcc
> I also tried on Redhat Linux 5.5, succeeded, without error.
> Anyone have any idea?

To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list