[Samba] Win7 can't joint Samba domain?

Mike Eggleston mikeegg1 at mac.com
Sat Jul 2 21:23:31 MDT 2011

On Sat, 02 Jul 2011, Linda Walsh might have said:

> Mike Eggleston wrote:
> >On Fri, 01 Jul 2011, John Drescher might have said:
> >
> >>>We've been trying to get a newly loaded Win7 (64-bin) box to join our 
> >>>internal Samba domain. The error that keeps appearing is the win7 box 
> >>>can't find the domain controller and is looking for the registry keys 
> >>>NetpLoadParameters DNSNameResolutionRequired. We've set these registry 
> >>>keys before on other boxes, and have tried on this box, and stuff isn't 
> >>>working?
> >>>
> >>>Any suggestions on what to try?
> >>>
> >>http://wiki.samba.org/index.php/Windows7
> >>
> >>Also search for the samba mailing list trust issues with windows7
> >>machines. In this you will find how to disable the machine password
> >>updates.
> >>
> >>John
> >
> >John (and anyone else),
> >
> >That link says the same registry keys we're trying to set. Attempting to
> >join the Samba domain is still failing with an error those registry keys
> >cannot be found. This same installation disk was used to install Win7
> >on another box and it worked just fine. I can't think of any changes. I
> >don't understand why the previous box and win7 worked and this new box
> >with win7 is failing.
> ----
> 	1) The Wiki page, I feel is unclear.  It uses CCS to stand for 
> 	CurrentControlSet, i.e. put this in a .reg file and merge it from the 
> desktop...
> ----
> Windows Registry Editor Version 5.00
> [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]
> "DNSNameResolutionRequired"=dword:00000000
> "DomainCompatibilityMode"=dword:00000001
> ----
> 	Have you looked at a wireshark trace?

This is fixed now. I don't understand why the first several attempts
failed. I had the installer use a Dell recovery DVD rather than a DVD
ISO I pulled from Microsoft. Anyway, things should be ready for the user
on Tuesday afternoon.


More information about the samba mailing list