[Samba] SMB2 Negotiate Request

Mike Smith spammi.spamerson at gmail.com
Wed Jan 19 18:51:45 MST 2011

Thanks for the reply. I have set "max protocol = smb2" and I can use the 
SMB2 protocol fine. I'll try and explain my issue better:

When I say "negotiate request" and I talking about the packets that are 
sent between the client and server. The SMB2 protocol is driven by 
requests from the client and responses from the server. The very first 
packet that is sent from client to server contains a header and a 
message (SMB2_NEGOTIATE) that tells the server what dialects of the 
protocol the client understands.

When I send this packet the samba server does not respond to it, and I 
time out.  Windows 7 responds to this packet as expected.

If I use a SMB packet (instead of SMB2) and use that to negotiate a SMB2 
connection, it will work, but what I want to know is if there is a 
reason it's not responding the the SMB2 packet as it (apparently) should.


On 11-01-19 04:51 PM, Jeremy Allison wrote:
> On Wed, Jan 19, 2011 at 04:48:29PM -0800, Mike Smith wrote:
>> I am using samba 3.5.4 (and have tried 3.5.6) and have noticed that
>> samba does not respond to SMB2 negotiate requests. If I use a SMB
>> request to negotiate SMB2 it works fine. Does anyone know if there
>> is there a reason for this, or is it a bug? I have tried searching
>> for an answer but haven't been able to come up with anything.
> You need to set "max protocol = SMB2" to make smbd respond
> to SMB2 requests. However I don't recommend turning it on
> in 3.5.x, it has been completed for 3.6.0 (there are a few
> ambitious sites using it in production). To check out 3.6.0
> pull the git v3-6-test branch.
> Jeremy.

More information about the samba mailing list