[Samba] [SOLVED] Re: Domain controller could not be contacted

Mark Fox mark.fox at gmail.com
Tue Feb 22 13:08:34 MST 2011

Got frustrated and decided to do something I don't normally do: Take lunch.
Came back and noticed that things were working better than before.
Eventually, I tried logging onto the domain. It worked. Tried joining a
machine to the domain, that worked too.

Confused, I checked my notes and just before lunch I had restarted nmbd.

Here's my guess as to what was going on: The server that was acting as the
PDC, wasn't acting as the WINS server. An older Samba server was. This
morning, thinking that the problem was between the different versions of
Samba, I disabled WINS on the old server, and enabled it on the new server.
I restarted smbd, but not nmbd. Later, I restarted nmbd. The problem may
have had nothing to do with the different versions of Samba. It could also
have been as a result of the upgrading breaking the network configuration on
the PDC (it uses bonding). I was messing with that this morning as well.
Maybe it just took a little while for ARP and such to settle down.

Tentatively, I'm happy.


On Tue, Feb 22, 2011 at 11:38 AM, Mark Fox <mark.fox at gmail.com> wrote:

> I recently upgrade a Samba server, that was happily acting as a PDC for a
> school, from 3.2 to 3.4.7. This was done via an upgrade to Ubuntu (from 9.04
> to 10.04LTS). Of course, the Ubuntu upgrade caused a bunch of issues, most
> of which were managed without undue stress. The remaining issues are with
> Samba's configuration.
> This is a fairly simple Samba configuration using the TDB password backend,
> no LDAP.
> After the upgrade, domain logons do not work, nor can new machines be
> joined to the domain. From a Windows XP machine, attempting to log on gives
> "The system can not log you on now because the domain CK is not available."
> Attempting to join the domain yields: "A domain controller for the domain
> CK could not be contacted. Ensure that the domain name is typed correctly.
> [...]"  In the details for this message, it states that "The following error
> occurred when DNS was queried for the service location (SRV) resource record
> used to locate a domain controller for domain CK: The error was: 'DNS name
> does not exist.'" It also states that "The query was for the SRV record for
> _ldap._tcp.dc._msdcs.CK" This seems strange because we aren't using LDAP.
> Workgroup machines work. But they can't browse the domain. Going directly
> to a share on the server via the FQDN works. This looks like a winbindd
> issue to me. On the Linux side, connecting to a share on the server with
> smbclient works fine. In all honesty, I don't have much knowledge of tools
> for debugging NetBIOS issues with Samba. It's always just worked for me.
> Any ideas what could be going on here? Suggestions for further inquiry?
> Mark

More information about the samba mailing list