[Samba] Samba Cross-Compilation Problem

Hitesh Bajaj hitesh_bajaj24 at yahoo.com
Sun Feb 20 23:25:09 MST 2011

Tool Chain: I am using montavista (mv_pro_5.0)tool chain.Samba Version: I Used - samba-3.5.6.Error: error: ADS_STRUCT has no member named ldapThen I Switched To Version samba-3.4.10Then I got the Same Error.
EnvironMent I Set Accroding Are:
1) export CONFIG_SITE=/home/hitesh/Sources/config.site2) export PREFIX="arm_v5t_le"3) export CC="${PREFIX}-gcc"4) export LD="${PREFIX}-ld"5) export NM="${PREFIX}-nm -B"6) export AR="${PREFIX}-ar"7) export RANLIB="${PREFIX}-ranlib"8) export LN_S="ln -s"
9) export PKG_CONFIG_PATH=/opt/mv_pro_5.0/montavista/pro/devkit/arm/v5t_le/target/usr/lib/pkgconfig

10)export LD_LIBRARY_PATH=/opt/mv_pro_5.0/montavista/pro/devkit/arm/v5t_le/lib/11)export LDFLAGS=-L/opt/mv_pro_5.0/montavista/pro/devkit/arm/v5t_le/lib/12)export CPPFLAGS=-I/opt/mv_pro_5.0/montavista/pro/devkit/arm/v5t_le/include/13) export LIBS="-L/opt/mv_pro_5.0/montavista/pro/devkit/arm/v5t_le/target/lib -L/opt/mv_pro_5.0/montavista/pro/devkit/arm/v5t_le/target/usr/lib"

Then I Configured Samba As:
./configure --host=i686 --target=arm-linux --prefix=/home/hitesh/samba/samba-05 
I have already wasted lot of time in this.
Help Will Be Highly Appreciated.

--- On Sun, 20/2/11, Richard Sharpe <realrichardsharpe at gmail.com> wrote:

From: Richard Sharpe <realrichardsharpe at gmail.com>
Subject: Re: Samba Cross-Compilation Problem
To: "Hitesh Bajaj" <hitesh_bajaj24 at yahoo.com>
Cc: samba-technical at lists.samba.org, "Samba Listing" <samba at lists.samba.org>
Date: Sunday, 20 February, 2011, 7:36 AM

On Fri, Feb 18, 2011 at 8:44 AM, Hitesh Bajaj <hitesh_bajaj24 at yahoo.com> wrote:
> Hi,
> I want to cross-compile samba for arm-linux.
> I have host machine: Red Had Enterprise Edition 5.0 and I am not able to cross compile it.
> I tried 3-4 Versions of samba but in vain.
> Can you guide me through compiling process.Which stable version of samba should i use?Step by step cross compilation process.OR
> If you have binaries or package for samba which i can directly use  at my arm machine.

Well, this worked for me with Samba 3.4.4 or thereabouts around March
2010 and later.

You would be better off to tell us:

1. What tool chain you are using?
2. What version of Samba you are trying to cross compile?
3. What specific problem you are seeing?

It really was a matter of simply making sure that the bin directory
for the tool chain was in my path, running configure with the correct
arg to select the tool chain and then running make.

Richard Sharpe

More information about the samba mailing list