[Samba] application can not delete from samba share

Nemeth Zoltan nzoli73 at freemail.hu
Thu Feb 3 05:07:24 MST 2011

Hello Daniel

Thank you for hints
the application is running on WinOs and the files what 
should be deleted on linux-samba share.
I checked the mentioned acl sttings , but simpthom is sill 
the same :
- only this win application is not able to delete from samba 
- same appl can delete on other shares well

The question is with other words: how can I setup totally 
same emulation on samba as WinOS shares are ?
How can I found out the reason, why delete from samba is 
different from winappl. point of view then other shares.

Thank you for any answers
regards: Zoltan

-------- Eredeti üzenet --------
Tárgy: AW: [Samba] application can not delete from samba share
Feladó: Daniel Müller <mueller at tropenklinik.de>
Címzett: nzoli73 at freemail.hu, samba at lists.samba.org
Dátum: 2/3/2011 11:00 AM

> Hello,
> with samba3 many things changed. For me too coming from samba 2x
> to samba3 the first thing was that office files could no longer be saved as
> I was used without problem with samba 2x.
> Try to set the sticky bit for the user or the group(1770 2770)the
> application is
> running. It solved me many problems.
> Or try in your [share]  profile acls = yes
>   nt acl support = no
> Good Luck
> -----------------------------------------------
> EDV Daniel Müller
> Leitung EDV
> Tropenklinik Paul-Lechler-Krankenhaus
> Paul-Lechler-Str. 24
> 72076 Tübingen
> Tel.: 07071/206-463, Fax: 07071/206-499
> eMail: mueller at tropenklinik.de
> Internet: www.tropenklinik.de
> -----------------------------------------------
> -----Ursprüngliche Nachricht-----
> Von: samba-bounces at lists.samba.org [mailto:samba-bounces at lists.samba.org] Im
> Auftrag von Nemeth Zoltan
> Gesendet: Donnerstag, 3. Februar 2011 10:11
> An: samba at lists.samba.org
> Betreff: [Samba] application can not delete from samba share
> Dear All
> I am stucked with a problem ,  I'd like to ask your help.
> Problem :
> - I can not delete files from  Samba_3.2.5 share from a specific windows
> application. Filemanagers, command prompt can handle the files well.
> The checked things:
> - the same application was able to delete from samba_2.x
> - permissions are OK. From windows explorer or from command prompt I can
> delete well. Create files, delete, modify perfect from WinOS  but from
> this application is not possible.
> -acls , SIDs seems to be OK. getfacl rwxrwxrwx
> - this application is able to delete from other shares except  the files
> are on samba
> - log level 10: I could not recognized any failure or strange behaviour
> - I have tried many settings in smb.conf : oplock, case sensitive
> settings etc .. without success
> I monitored the successful deleting from a file-manager and compared
> with unsuccessful one (this application) . Some this are different
> between logs but I am not able to catch the reason of problem. I can
> provide logs or screenshoot about comparison if needed.
> Have you already experienced such a problem. I appreciate any help
> Thank you
> regards: Zoltan

More information about the samba mailing list