[Samba] Setting ACL permissions from Windows

parker support at pegmicro.com
Tue Feb 1 10:34:53 MST 2011

Thanks Lynn, and Michele I will try to get this done. I'm a bit of a newb so
I can't see myself posting back right away. I have set up my linux box with
a software RAID so I have to go research the repercussions on my file system
when I change the fstab file


From: Lynn Dixon [mailto:boodaddy at gmail.com] 
Sent: Monday, January 31, 2011 10:38 PM
To: parker
Subject: Re: [Samba] Setting ACL permissions from Windows


IF the files system you are trying to acess is on a linux machine, make sure
it is mounted with user_xattr and acl options in your /etc/fstab

I ran into this same problem a week or so ago.  Once I mounted the the
filesystem with those options, it worked perfectly. Just remember, that any
folders that were created may not have the new attributes unless you
re-create them or re-acl them.

On Mon, Jan 31, 2011 at 9:47 PM, parker <support at pegmicro.com> wrote:

I know I have seen something on this list about this very topic, but I don't
remember a solution posted. I have a Samba server joined to a Windows 2003
domain. On the Samba machine wbinfo -u and -g successfully gets me user and
group lists from the AD machine. Getent passwd and getent user both return
information from the domain, but I still can't Set permissions. I have tried
to create directories under the main share using windows. That works, but
when I try to set their permissions I get "Unable to save permission changes
on (folder). The
parameter is incorrect."

To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba


More information about the samba mailing list