[Samba] Samba shares and MS Office 2010 locking

Jason Voorhees jvoorhees1 at gmail.com
Wed Dec 14 12:00:59 MST 2011

Hi people:

I'm using Samba 3.5.11 with some sharing settings like these:

        workgroup = MARKETING
        netbios name = SMBSERVER
        server string = Samba, OpenLDAP Server
        obey pam restrictions = Yes
        passdb backend = ldapsam:"ldap://localhost"
        passwd program = /usr/sbin/smbldap-passwd %u
        passwd chat = *New*password* %n\n *Retype*new*password* %n\n
        client lanman auth = Yes
        log level = 2
        log file = /var/log/samba/samba.log
        time server = Yes
        printcap name = cups
        add user script = /usr/sbin/smbldap-useradd -m "%u"
        delete user script = /usr/sbin/smbldap-userdel "%u"
        add group script = /usr/sbin/smbldap-groupadd -p "%g"
        delete group script = /usr/sbin/smbldap-groupdel "%g"
        add user to group script = /usr/sbin/smbldap-groupmod -m "%u" "%g"
        delete user from group script = /usr/sbin/smbldap-groupmod -x "%u" "%g"
        set primary group script = /usr/sbin/smbldap-usermod -g "%g" "%u"
        add machine script = /usr/sbin/smbldap-useradd -w "%u"
        logon path =
        logon home =
        domain logons = Yes
        preferred master = Yes
        domain master = Yes
        wins support = Yes
        ldap admin dn = cn=admin,dc=marketing-alterno,dc=com
        ldap delete dn = Yes
        ldap group suffix = ou=groups
        ldap idmap suffix = ou=people
        ldap machine suffix = ou=machines
        ldap passwd sync = yes
        ldap suffix = dc=marketing-alterno,dc=com
        ldap ssl = no
        ldap user suffix = ou=people

	path = /var/samba/sharing
	valid users = @accounting, "@Domain Admins"
	admin users = "@Domain Admins"
	read only = No
	inherit permissions = Yes
	vfs objects = recycle
	recycle:exclude = *.tmp|*.TMP|*.temp|*.o|*.obj|~$*|*.~??|*.log|*.trace
	recycle:versions = yes
	recycle:keeptree = yes
	recycle:repository = .trash

Many times when a user open, modifies and then close a Office 2010
document (Word, Excel, Power Point), the file keeps locked. A
different user tries to open the file and gets a error message related
to locking, read only permissions or something similar.
After a unknown amount of time (it could be seconds, minutes, i'm not
sure how long) the locking seems to dissapear. I tried some options
settings related to file locking without success. There are so many
options that using the right combination of them to achieve the
expected result is difficult to me.

Does anybody has experimented and solved this issue? I hope someone can help me.


More information about the samba mailing list