[Samba] help with user permissions

Ben George bentech4you at gmail.com
Tue Sep 28 09:22:37 MDT 2010


My Name is Ben.T.George

i successfully installed samba and other all dependencies on my Solaris 10
(SPARC) machine.

i stopped the default samba and swat and enabled these 2 from the installed
location (/usr/local/samba/sbin)

then i edited the smb.conf using swat.after that i got a smb.conf like this\

# Samba config file created using SWAT
# from UNKNOWN (ÿ¿û )
# Date: 2010/09/28 16:30:12

    workgroup = GROUP
    hosts allow = 192.168.1.

    path = /export/home/user1
    valid users = user1

    path = /export/home/ramana
    valid users = ramana

    path = /export/home/teju
    valid users = teju
    path = /export/home/user1
    valid users = user1

after that i created these 3 user's and set password (smbpassword and normal

then i added one windows xp machine to this same GROUP,i can view these
shared folders there

then my problem is when i access that particular shared folders,every time
one folder opens,when i try to access other 2 ,it says not accessible

after that i tried to create these same users on windows,i logged another
user and tried,,then the folder permission changed
still i can access another folder and other 2 are not accessible..

every time these changed according to the user.

please help me to solve these....without giving "valid users" it works
perfect for me



More information about the samba mailing list