[Samba] [Solved] Re: networking problem/Domain not available

Robert S robert at spotswood-computer.net
Mon Nov 29 21:34:38 MST 2010

On Monday, November 29, 2010 09:02:32 am Allen Chen wrote:
> Did you power off and power on the other 2 old switches?
> Alllen

Well, it appears Allen had the right solution, and I would have stumbled on it 
by accident. Over the holiday, we had a squirrel commit suicide on a 
transformer so everything got powered off and later back on. When I changed 
the cabling today to do the tests suggested by others, it worked! Thanks to 
all who tried to help me.

> Robert S wrote:
> > I've got a client - a cheap client - and they want to add a new file
> > server (samba sharing) to their network. They have one samba server
> > already acting as the domain controller (PDC) and file server (and DHCP
> > server). The wiring is a nightmare, and everything is daisy chained
> > through 3 different non- programmable switches. They have no more open
> > ports on any of the switches. Further, the switches are about 40 feet
> > from the servers in another room.
> > 
> > My plan was to take the cable that connects the domain controller (PDC),
> > plug that into a new switch as the uplink, then connect both the old and
> > new samba servers (a member server according to testparm) to the same
> > switch. The new switch has all auto-uplink ports, so cross-over,
> > non-cross-over isn't an issue.
> > 
> > The problem is when I do this, none of the workstations (XP based) can
> > find the domain controller any more (domain not available). I switch the
> > cables back (remove the switch), everything works fine. Use the switch
> > again, same problem. This means it's not the signorseal problem.
> > 
> > For kicks to see if it's a bad cable or switch, I used a live Linux CD on
> > my test workstation (this one is having the problem) when the connection
> > is running through the new switch and it got a lease from the PDC (it's
> > also a DHCP server) and can ping the PDC no problem. This, to me, says
> > it can't be the cable or new switch and is pointing the finger at XP.
> > 
> > But what is causing XP to fail? Domain authentications with very tiny
> > TTL??? Any other troubleshooting tips?

Fail to learn history-repeat it.
Fail to learn rights-lose them.
Learn both-get screwed by previous two groups.

More information about the samba mailing list