[Samba] samba 3.5.3 time-stamping issue

Oliver Freyd Oliver.Freyd at iontof.com
Wed May 26 02:34:54 MDT 2010

Björn Jacke schrieb:
> Hi Oliver,
> On 2010-05-21 at 16:47 +0200 Oliver Freyd sent off:
>> This happens on a amd64 machine, running debian lenny on top of
>> debian etch (with xen-3.0.3).
>> The virtual machine that runs samba-3.5.3 runs linux kernel 2.6.18.
>> Linux samba-fs1a 2.6.18-6-xen-amd64 #1 SMP Fri Aug 21 16:46:08 UTC
>> 2009 x86_64 GNU/Linux
>> On another machine I tried debian lenny, kernel 2.6.26-2, no xen,
>> i686 (32 bit), samba3.5.3 runs flawlessly there.
>> Somehow setting timestamps is broken by running an old kernel, or on amd64.
> running a new glibc on an ancient kernel is known to be broken. glibc provides
> functionality that the kernel does not really support. Even if we tried to we
> can't test at compile time that all the functions that we find do actually work
> as a lot of them require root privileges but samba mostly is not compiled as
> root. Unless you desex Samba by some functionality manually there there are just
> two ways to fix your issue: compile samba with a glibc that has an age not newer
> than your or update the kernel. If 2.6.18 is the kernel that you have to stick
> to because of xen then there is only one way left ;-)
> Björn
Actually I just upgraded the xen "mother" to lenny, and xen 3.2, because 
I wasn't able to boot the lenny kernel on the domU. For now it seems to 
work fine.

BTW, the hires timestamps only work if the filesystem does support them,
and ext3 from lenny doesn't, but xfs does, and probably also ext4.

Is the windows ACL support in vfs_acl_xattr supposed to work in 3.5, or 
is it still considered experimental. Are people using it in production 

many thanks,


More information about the samba mailing list