[Samba] samba 3.5.3 time-stamping issue

Björn Jacke bj at SerNet.DE
Wed May 26 02:04:00 MDT 2010

Hi Oliver,

On 2010-05-21 at 16:47 +0200 Oliver Freyd sent off:
> This happens on a amd64 machine, running debian lenny on top of
> debian etch (with xen-3.0.3).
> The virtual machine that runs samba-3.5.3 runs linux kernel 2.6.18.
> Linux samba-fs1a 2.6.18-6-xen-amd64 #1 SMP Fri Aug 21 16:46:08 UTC
> 2009 x86_64 GNU/Linux
> On another machine I tried debian lenny, kernel 2.6.26-2, no xen,
> i686 (32 bit), samba3.5.3 runs flawlessly there.
> Somehow setting timestamps is broken by running an old kernel, or on amd64.

running a new glibc on an ancient kernel is known to be broken. glibc provides
functionality that the kernel does not really support. Even if we tried to we
can't test at compile time that all the functions that we find do actually work
as a lot of them require root privileges but samba mostly is not compiled as
root. Unless you desex Samba by some functionality manually there there are just
two ways to fix your issue: compile samba with a glibc that has an age not newer
than your or update the kernel. If 2.6.18 is the kernel that you have to stick
to because of xen then there is only one way left ;-)

SerNet GmbH, Bahnhofsallee 1b, 37081 Göttingen
phone: +49-551-370000-0, fax: +49-551-370000-9
AG Göttingen, HRB 2816, GF: Dr. Johannes Loxen

More information about the samba mailing list